Emergency Maintenance - Billing Platform
Incident Report for Anchor Systems
Resolved
This emergency maintenance has been completed and the services are once again operational. Please reach out to our support team if you experience any issues.
Posted Mar 02, 2021 - 09:32 AEDT
Investigating
Please be aware that we are performing emergency maintenance on our billing platform. Some services may be unavailable during this time. We will provide further updates as things progress.
Posted Mar 02, 2021 - 09:23 AEDT
This incident affected: Anchor Client Area.