Fire drill underway at Sydney office
Incident Report for Anchor Systems
Resolved
This incident has been resolved.
Posted May 18, 2021 - 11:18 AEST
Monitoring
Please be aware that there is a fire drill currently underway at our Sydney office. While this is underway, there will be delays to ticket responses and phone support.
Posted May 18, 2021 - 11:09 AEST
This incident affected: Phone Support and Ticket Support.